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Report Creation
SubTotal
SubTotal - Others Total (Old vs New)

$QVVAL(___) 

Calcs
Calcs Driven by QV Values:  Parameterized Calcs
Calcs Driven by Time Series Values

Scan

Report Formatting and Options
Templates
Marker Options

DiveBook Topic QuickViews

In this course, we will cover Tips and Tricks 
for the following:
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Report Creation:  SubTotal Reports

Objective:  Certain “metrics” must be calculated at a detail level 
but reported at a summary level.

# customers or # people meeting certain criteria

Elements of the subtotal report
• "Product Groups" QuickView
• list of "Salespersons”
• columns showing sales for 2 periods
• column for number of New Placements
• Totals at bottom

A New Placement is a customer that purchased this period but not in a previous period. 
The "New Placement" calc must be done at the customer level and can not be done at the 
salesperson level.

It is very useful to view the metric at the salesperson level without seeing all the detail.

You can not dive off this report since you are actually looking at a subtotal.  Any dive will only show 
the last row in the underlying multi-tab.

Take a look at the calculation, this is what we needed to ask before its creation:

New Placement definition (what it IS and IS NOT):

If Cases were shipped the Last 3 Months and this Month, then it's not a New Placement.
If Cases were shipped the last 3 Months and not this month, then it's not a New Placement.
If Cases were not shipped the Last 3 Months and Cases were shipped this month, then it is a New 
Placement.
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Workshop 1: Report Creation: SubTotal Reports

Key Elements 
• Create calc field(s) for the “metric” (e.g. 0 or 1)
• “Metric” calc option – “Always Sum Total”
• Create multi-tab window

• 1st  dive is “summary” or reporting field (Salesperson)
• 2nd dive is “metric” related field (Customer)

• Convert to subtotal report
• Delete items related to “metric” related field

Workshop 1:

1. Launch ProDiver and open subtotalreport.mrk
2. Display > Tabular to convert to the underlying multi-tab

note:  view the calc for "New Placement“
|if(and(calc[Cases Prior3]<0,calc[Cases Current]>0),1,0)

3. Display > Report…
4. Change Report Style to "Indented 2 Level MultiTab"
5. OK
6. Unlock the report
7. Highlight all items on the same row as the customer name
8. Delete these items
9. Highlight the salesperson name in large font
10. Delete these items
11. Continue to modify the Report appearance

Note:
You can not dive off this report since you are actually looking at a subtotal.  Any dive will 

only show the last row in the underlying multi-tab.
Try it and see what you get.
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Report Creation:  SubTotal - Others  - Total

Objective 

On a “focused” Report show :

Revenue SubTotal for displayed rows
Revenue SubTotal for non-displayed rows
Total Revenue for all rows
Also show percentages !!!
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Workshop 2:  Report Creation  SubTotal -
Others Total (Old)

Workshop 2:

1.  Open ProDiver > sales.dvp
2.  Dive on Customer County
3.  Delete all current summaries and add:

Revenue  =  Total[Revenue]
Revenue % of Total =  % Total[Revenue]
Parent Revenue  =  parent(Total[Revenue])
Revenue Other  =  calc[Parent Revenue]-Total[Revenue]
Options = Don't Show Total
Pct Other  = 100-% Total[Revenue]
Options = Don't Show Total

4.  FIND top 10 Customer County 
Sort  Down (Revenue)
Find > First 10 Items
Focus + Group
Find All

Note :
- the value for "Parent Revenue" does not change
- on Subtotal row, all values except Parent Revenue have changed

5.  Convert to report window
6.  Unlock report window
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Workshop 2 continued:

7.  Insert item -
- same properties as "Subtotal" 

Click "Subtotal" and choose Add Item
- change item type text from "$TOTAL_STRING" to "Others"
- vertical offset of 20
- remove line above "Others"

Edit Item > Style > Top Line= None
8.  Insert item -

- same properties as "Subtotal" 
- change item type text from "$TOTAL_STRING" to "Total"
- vertical offset of 40
- remove line above "Total"

9.  Insert item -
- same properties as "Revenue" Subtotal value (the number) 
- change Summary Name from "Revenue" to   "Revenue Other"
- vertical offset of 20
- remove line above value

10. Insert item -
- same properties as "Revenue" Subtotal value  (the number) 
- change Summary Name from "Revenue" to "Parent Revenue"
- vertical offset of 40
- remove line above value

11. Insert item -
- same properties as "Revenue % of Total" Subtotal   value (the number) 
- change Summary Name from "Revenue % of Total" to "Pct Other"
- vertical offset of 20
- remove line above value

12. Insert item -
- same properties as "Total"
- change item type text from "Total" to "100.0"
- change position to column "c"
- right align

13.  Change report to TOP 5, then TOP 10
Note: all the subtotal values and % change  appropriately

14.  Delete these columns on final report :
Parent Revenue
Revenue Other
Pct Other 
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Workshop 3:  Report Creation:  SubTotal -
Others Total (New)

Workshop 3:

1. Open ProDiver >  sales.dvp
2. Dive on Customer County
3. Delete all current summaries and add:

Revenue  =  Total[Revenue]
Revenue % of Total  =  % Total[Revenue]

4. Sort Down on Revenue
5. Find > First 10
6. Focus > Group with Others
7. Select Display > Report
8. Tabular with Others > Totals = Bottom
9. Click OK
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$QVVAL(___)

Objective :  Place selected QuickView value in a Report title or
column header

Not all QuickView names appear in Parent Dimension
Item Types area

External Model  QVs
Time series wizard QVs

$QVVAL(___)       where ___ = QV name
QV name Edit > Edit QuickViews...
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Workshop 4: External Model:  $QVVAL(___)

Workshop 4:

1. Open ProDiver
2. Open sales.mrk
3. Unlock report
4. Click <Add Item>
5. Select Item Type = Parent Dimension Value
6. Click "One Parent" radio button
7. Click down arrow

Note:  - absence of "Metric" QV
8. Exit ProDiver
----------------------------------------------------
1. Open ProDiver
2. Open sales.mrk

Note:
- Metric QV contains 4 values
- Metric column contains data for Metric selected
- Metric selected is contained in title

3. Unlock report
4. D-click title "Metric Selected = ..."  

Note:  - $QVVAL(metric)
5. Exit ProDiver
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Workshop 5: Time Series $QVVAL(___)

Workshop 5:

1. Launch ProDiver
2. Open ts-qvval-sales.mrk
3. Unlock Report
4. Click <Add Item>
5. Select Item Type = Parent Dimension Value
6. Click "One Parent" radio button
7. Click down arrow
8. Change position > Column A
9. Note:  - absence of "Time Series Current Date" QV
10. Exit Diver
----------------------------------------------------

1. Launch ProDiver
2. Open ts-qvval-sales.mrk

Note:  - End Date QV contains 4 values
3. Edit > Edit QuickViews...

Note:  - The name of the QV is actually "Time Series Current Date"
4. Close
5. Unlock Report
6. Add item  > $QVVAL(Time Series Current Date)
7. Select text and add:  Rolling 12 Months Ending
8. Lock Report and change the End Date Quickview Value > Go

Note:  - the change in the Title Bar
9. Exit Diver
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Calcs Driven by QV Values 

Objective:  Have QV value determine contents of summary 
column/calc

Normally you would create multiple Markers if wanted to have a 
report for Revenue and Units.  Now you can think of a Marker as a 
program with a variable and a QV as a way to pass that variable’s 
value into the program.

So... you should be able to reduce the number of Markers

Must be External QuickView ( e.g. Metric )
$(____)____ = QV name
Total[Revenue]   or   Total[Units]    Total[$(Metric)] 
External QV Model

must be open when creating calc
remember to close prior to saving Marker

Try not to include "$" in a field name – confusing
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Metric = Revenue

Metric = Units

Workshop 6: Calcs Driven by QV Values:

Workshop 6:

1. Launch ProDiver
2. Open sales.mrk

Note: Metric column equals column with same name as the Metric QV (e.g. Units)
3. Select "Revenue" in Metric QV

Note: Metric column values change
4. D-click Metric column header

Note: definition = Total[$(Metric)]
----------------------------------------------
1. Launch ProDiver
2. Open sales.mrk
3. Edit > Add QuickViews... > Add
4. Check Skip "All Values"
5. Select "External" DivePlan Type
6. Browse...
7. Select "metric.mdl"
8. Open
9. OK > Close
10. Open sales.dvp
11. Dive on Company
12. Edit > Edit Columns...> Add 
13. Key "Metric" into Name box
14. Key "Total[$(Metric)]" into definition box
15. OK
16. Edit > Select Columns...
17. D-click "Metric"

Note: it should now be in Selected box
18. OK

Note: Metric column = Revenue column
19. Select "Units" in Metric QV

Note: Metric column = Units column
20. In Console, r-click "metric.mdl" and Close
21. File > Save Marker...
22. File > Close 
23. Reopen Marker just saved and re-test
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Calcs Driven by QV Values

Option 1
- create 1 Marker per 
variation

Option 2
- modify existing Marker to 
allow user to select desired 
metric
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Workshop 7: Calcs Driven by QV Values:

Workshop 7:

1. Open ProDiver
2. Open qv-metric-sales-report.mrk
3. Delete all Summaries
4. Add a Summary named “Summary”
5. Define it as calc[Metric]
6. Change to Report View
7. Unlock the Report
8. Edit Item  = Summary
9. Change to Item Type: Text
10. Definition:  $QVVAL(Metric)
11. Add Item
12. $QVVAL(Metric)
13. Text > Trailing Text > Report > Click OK
14. Update the QuickView and see the Report change!
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Calcs Driven by Time Series QVs

What can Time Series do for me ?

Similar to “Calcs Driven by QV Values” but with a twist
Marker is a variable program controlled by a QuickView
Reduce the number of Markers

Time Series Control Panel is THE interface
Creates QuickViews ;  but …

YearMonth Current Date time series = YearMonth
metric       = Current Date

Creates Named Groups ;  but …
ts YearMonth p YTD ts = time series = YearMonth

p  = period        = YTD
Time Series Control Panel is THE interface
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Workshop 8:  Calcs Driven by Time Series QVs

Workshop 8:

1. Open ProDiver > rolling-sales.mdl
2. Dive on "Year Month"
3. Define "Year Month" as a period
4. Remove all Summary fields from dive window
5. Edit > Time Series Control Panel...
6. Add...
7. Name time series same as Dimension with spaces removed:    "YearMonth"
8. Uncheck "Include Time Series Label in QuickView Bar
9. Name current date same as time series with "Current" appended : "YearMonth

Current"
10. Select Date Definition:  Date Set by QuickView
11. Next >
12. Select "Rolling Periods" Template
13. Change Number of Periods to 12
14. Note : naming convention
14. Next >
15. D-click "Cases"
16. Finish
17. OK
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Workshop 8 continued:

18. Review what just happened :
One QuickView was created

- name is "YearMonth Current Date"
Edit > Edit QuickViews...

- QV label is "YearMonth Current"
12 Named Groups created
ts YearMonth p Current Period
ts YearMonth p Previous Period
ts YearMonth p Current Period -2
...
ts YearMonth p Current Period -11
12 Calcs/Columns created
Cases Current Period     = calc[Cases,Year Month="ts YearMonth p Current Period"]
Cases Previous Period    = calc[Cases,Year Month="ts YearMonth p Previous Period"]
Cases Current Period -2  = calc[Cases,Year Month="ts YearMonth p Current Period -2"]
...
Cases Current Period -11 = calc[Cases,Year Month="ts YearMonth p Current Period -11"]
QuickViews -

- can be re-ordered in Edit QuickViews box
- are not editable in Edit QuickViews box

Named Groups -
- are visible in Edit Column box
- are not editable in Edit Named Group Box

19. Check cell values for correctness
20. Close "Year Month" window
21. Dive on "Sales Manager"
22. Convert to Report; provide title of "Rolling 12 Months"
23. Unlock Report
24. Edit each Summary column in turn

- Item Type = Group Value
25. Review column headers for correctness
26. Select different values and check for correctness
27. File > Page Setup > Landscape
28. Save Marker

Workshop 8: Calcs Driven by Time Series QVs
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The Future is Now
Freedom of choice
Fewer Markers
Re-think your current Reports

Prepare
Invest some time now

Self-study
DI Training

KISS applies as you start out

Calcs Driven by Time Series QVs
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Objective:  Allows user to get a portion of a string when you 

know the separator but not the length.

Scan

Separate Customer Name  and Customer 
Number from Dimension “Customer.”

“(“ is the separator.

Syntax: scan(string,token number,delimiters)

In the example above, the “(“ is a separator.   In a Patient Name, it might 
be “ , “ as in: “Smith, Janet”.

A token is a segment of the string; delimiter is the separator.
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Workshop 9: Scan

Workshop 9:

1. Open ProDiver > divebook.dbk > Ad Hoc Analysis: 2 Years MTD
2. Double click an empty column header to create a new column
3. Name the column Customer Number
4. Definition:  substr(scan(Dimension[Customer],2,"("),2,5)

** Because you know the length is 5 characters for the Customer 
Number and want just the NUMBER without the “(“

5. Sort the column ascending by highlighting the column and clicking the 
sort up icon in the tool bar

6. Double click an empty column header to create a new column
7. Name the column Customer Name
8. Definition:  scan(Dimension[Customer],1,”(“)

** Because the length varies
9. Sort the column ascending by highlighting the column and clicking the 

sort up icon in the tool bar
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Objective

- Format Report

- Save Report Template

- Load (apply) Report Template

Report Templates
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Report Template – Report Examples

Look at the details of this Report.

You can format colors, fonts, to have or not to have dates, page numbers, 
and aligning text left, right or center.

You can also specify decimal places.
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Report Template – Report Examples

Look at the details of this Report:

Alignment, indenting of lines, decimal places, coloring and font.
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Report Template – Report Examples

Look at the details of this Report:

Grid lines, decimal places, bold font, alignment text, and inclusion of the 
date.
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If a Report has previously been defined, and its Report Template saved, 
this Template can be used to create a Report from a different dive. 

Workshop 10: Report Template – Compatibility

Compatible

Workshop 10:

1. Open ProDiver > divebook.dbk
2. Ad Hoc Analysis:  2 Years: MTD
3. Dive on Sales > Salesperson
4. Revenue and Cases exist as Summaries
5. Add Cost
6. Choose > Display Report (or Report icon)
7. Choose Tabular
8. Edit Summary Layout > Stack By Group
9. Keep Defaults
10. Click OK
11. File  > Save Report Template > MT_stacked.rep > Save
12. Dive on Time  > Ship Month
13. Choose > Display Report (or Report icon)
14. Load Template > group_stacked.rep
15. (Review Compatible)
16. Open
17. File> Save Marker > Revenue by Ship Month

Compatible means the same number of Dimensions, Summeries, Infos.
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Mostly Compatible

Workshop 11: Report Template – Compatibility

Workshop 11:

1. Open ProDiver >  divebook.dbk
2. Ad Hoc Analysis:  2 Years: MTD
3. Dive on Sales > Salesperson
4. Revenue and Cases exist as Summaries
5. Remove Cases
6. Choose > Display Report (or Report icon)
7. Choose > group_stacked.rep > Save

Mostly Compatible means the number of Dimensions are the same, but the 
number of Summaries or Infos differ.
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Partially Compatible

Workshop 12: Report Template – Compatibility

Workshop 12:

1. Take back to Tabular
2. MT  Sales > Sales Manager
3. Choose > Display Report (or Report icon)
4. Load Template > group_stacked.rep
5. (Review Partially Compatible)
6. Open
7. Take a look at the Report, incomplete information (missing Sales

Manager)

Partially Compatible means that the number of Dimensions differ.
You may need to select a different Template if the current dive contains 

more Dimensions than the selected template. 
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Marker Options

Objective

• Save customized Marker settings

• Remove redundancy, and speed up the Marker’s 
performance

• Apply Report templates to tabular Markers
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Dive A – Dive D

Save a Marker with multiple 
Dive Windows

Dives - When saving a Marker, the Dive path(s) in that Marker can be set to 
open in Any Dive, open in a specific Dive (A, B, C, or D), or not save at all. 
When a Marker is being saved, the Dive A option is set to Dive A, the Dive B 
option is set to Dive B, etc. by default. At least one dive must be saved in the 
Marker.
Multiple dives cannot be saved to the same Dive letter. 
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External DivePlans

Centralize calcs, 
named groups, 
timeseries, etc.

External DivePlans:  Using the External DivePlan option, DivePlans can be 
saved external to a Marker rather than being included in the Marker file. 

Roger will be covering OLD vs NEW External DivePlan behavior in detail, 
but the idea is that the Internal and External DivePlans get merged into the 
Marker’s over all DivePlan.
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Extra DivePlans

Save a .dvp with a 
Marker

Useful in JUMP -
NetDiver, ProDiver

The Extra DivePlans option allows you to save the Marker so that when it is 
opened, additional DivePlans that were not used to create the Marker will 
also be opened. This feature is useful when using Jump.

3232



© 2010  Dimensional Insight, Inc.

Marker Options:

Additional 
Options

The Application Template option controls exactly how your screen looks, and which toolbar
and menu items can be used. 
* Not easy to return to default Toolbar/Menus.

The Close All Models when opening helps prevent a “Too Many Models” error if you 
frequently work with a large number of Models.
* Reduces Clutter in Console.

Remove Redundant Actions option may help speed Marker open time on large dives. 
* Cleans up Marker internals.

The MultiTab and MultiCrossTab Dive Report Template options allow a Tabular dive from 
the MultiTab or MultiCrossTab Report to have the formatting specified in the saved Template, 
rather than in the default Tabular Report formatting. 

The Area Name and Topic Name sections allow you to specify a DiveBook Area and Topic in 
which to save the Marker, DivePlan, or link.

The Marker Info area allows you to save a comment in the Marker and it will appear in the 
DiveBook’s Topic Info area.
• Four lines of comments allowed; does not apply to DivePlans or Models. 
Markers: You can view info in the File > Open > Select Marker info section.
DiveBooks:  Open DiveBook and choose Marker Topic, there’s a notes section for review
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DiveBook Area and Topic QuickViews

Objective

Customer is asking to view Sales numbers based on 3 
criteria:  Customer County, Product, and Supplier

Option 1
- Create 1 Marker per variation
- Save in DiveBook to be used as bookmarks to be 
accessed through the DiveBook

Option 2
- Create 1 Marker per variation
- Save in DiveBook
- Add a DiveBook Area and/or Topic QuickView for easy 
access

Using the DiveBook Area and Topic QuickView types allows an alternate 
way to present DiveBooks. It also allows direct access to open a DiveBook
topic, rather than requiring that you first display the DiveBook. 
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Workshop 13: QuickViews: 
DiveBook Area and  Topic 

Workshop 13:

1. Open ProDiver
2. Open divebook1.dbk
3. Review All 3 Topics by opening the DiveBook Icon and choosing them 

separately.
4. Close ProDiver.
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Workshop 14: QuickViews:  
DiveBook Area and  Topic 

Workshop 14:

Now, review the same DiveBook Area and Topics via a Marker with the 
DiveBook Topics as a QuickView.

1. Open ProDiver
2. Open  db-qv.mrk

Choose Edit > Edit QuickViews and take a look at how this is set up.
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